Lab59. Multilevel IS-IS

Tujuan Lab :

  • Menghubungkan beberapa level IS – IS yang berbeda, agar dapat saling berkomunikasi.

Topologi Lab :

multilevel-isisMetode Lab :

  • Set IP dan semua loopback router seperti topologi di atas.
  • Set R1 sebagai IS-IS Level 1, R2 sebagai Level 1/2 dan R3 sebagai IS-IS Level 2.
  • R1 dan R2 menggunakan area 49.0001 dan R3 area 49.0002.
  • Format NET address untuk R1 dan R2 yaitu 49.0001.00×0.0x00.x00x.00, dengan x adalah router number.
  • Format NET address untuk R3 yaitu 49.0002.00y0.0y00.y00y.00, dengan y adalah router number.
  • Set IS-IS circuit-type pada inteface router yang saling terhubung, sesuaikan dengan level IS-IS masing – masing routernya.

Verifikasi Lab :

  • Pastikan semua IP loopack router bisa saling ping.
  • Cek routing tabel, pastikan semua IP interface router sudah masuk.
  • Cek IS-IS neighbor dan database, pastikan tipe level IS-IS sesuai dengan topologi di atas.

Konfigurasi

Router R1

hostname R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
router isis
net 49.0001.0010.0100.1001.00
is-type level-1

Router R2

hostname R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0001.0020.0200.2002.00
(apabila kita tidak mengeset is-type nya maka secara default, router is-type nya akan bekerja sebagai L1 L2 )

Router R3

hostname R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.0030.0300.3003.00
is-type level-2-only

Verifikasi

Lihat neighbor pada masing – masing router, pastikan kondisinya UP semua. Kita juga bisa melihat tipe level IS-IS yg digunakan.

R1#sh isis neighbors

System Id      Type Interface   IP Address      State Holdtime Circuit Id
R2             L1   Fa0/0       12.12.12.2      UP    8        R2.02              
R1#
R2#sh isis neighbors

System Id      Type Interface   IP Address      State Holdtime Circuit Id
R1             L1   Fa0/0       12.12.12.1      UP    29       R2.02              
R3             L2   Fa0/1       23.23.23.3      UP    7        R3.02              
R2#
R3#sh isis neighbors

System Id      Type Interface   IP Address      State Holdtime Circuit Id
R2             L2   Fa0/0       23.23.23.2      UP    25       R3.02              
R3#

Lakukan ping ke semua IP loopback dari router, pastikan semuanya reply

R1#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/34/64 ms
R1#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/50/84 ms
R1#

Cek IS-IS databasenya

R1#sh isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R1.00-00            * 0x00000003   0xB232        719               0/0/0
R2.00-00              0x00000005   0x4F5E        819               1/0/0
R2.02-00              0x00000001   0xA00A        720               0/0/0
R1#
R2#sh isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R1.00-00              0x00000003   0xB232        696               0/0/0
R2.00-00            * 0x00000005   0x4F5E        800               1/0/0
R2.02-00            * 0x00000001   0xA00A        701               0/0/0
IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R2.00-00            * 0x00000005   0xFE91        795               0/0/0
R3.00-00              0x00000004   0x1136        793               0/0/0
R3.02-00              0x00000002   0x5675        793               0/0/0
R2#
R3#sh isis database

IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R2.00-00              0x00000005   0xFE91        777               0/0/0
R3.00-00            * 0x00000004   0x1136        779               0/0/0
R3.02-00            * 0x00000002   0x5675        779               0/0/0
R3#

Cek routing tabelnya.

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
i L2    1.1.1.1 [115/30] via 23.23.23.2, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
i L2    2.2.2.2 [115/20] via 23.23.23.2, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
i L2    12.12.12.0 [115/20] via 23.23.23.2, FastEthernet0/0
R3#
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
i L1    1.1.1.1 [115/20] via 12.12.12.1, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
i L2    3.3.3.3 [115/20] via 23.23.23.3, FastEthernet0/1
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
R2#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 12.12.12.2 to network 0.0.0.0

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
i L1    2.2.2.2 [115/20] via 12.12.12.2, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] via 12.12.12.2, FastEthernet0/0
R1#

level 1 hanya mengadvertise sesama levelnya saja. jadi untuk berkomunikasi dengan level 2 dia membuat default route ke router L1 L2

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.