L3VPN – BGP EIGRP

Read Concept here

1

Melanjutkan tulisan sebelumnya, pada tulisan ini akan membahas untuk menghubungkan antar PE-CE menggunakan BGP dan EIGRP. Intinya disini adalah koneksivitas antar PE-CE dan juga Redistribution.

First Step, Menghubungkan PE1 CE1 menggunakan BGP

PE1
PE1(config)#int e0/1
PE1(config-if)#vrf forwarding A
PE1(config-if)#no shut
PE1(config-if)#ip addr 101.101.101.1 255.255.255.0
PE1(config)#router bgp 100
PE1(config-router)#address-family ipv4 vrf A
PE1(config-router-af)#neigh 101.101.101.11 remote-as 200
PE1(config-router-af)#neigh 101.101.101.11 send-community extended
PE1(config-router-af)#neigh 101.101.101.11 activate

CE1
CE1(config)#int e0/0

CE1(config-if)#no shut
CE1(config-if)#ip addr 101.101.101.11 255.255.255.0
CE1(config-if)#int lo0
CE1(config-if)#ip addr 11.11.11.11 255.255.255.255
CE1(config-if)#router bgp 200
CE1(config-router)#address-family ipv4
CE1(config-router-af)#network 11.11.11.11 mask 255.255.255.255
CE1(config-router-af)#neigh 101.101.101.1 remote-as 100
CE1(config-router-af)#neigh 101.101.101.1 send-community extended
CE1(config-router-af)#neigh 101.101.101.1 activate

Verifikasi

CE1#sh ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

11.0.0.0/32 is subnetted, 2 subnets
B        11.11.11.1 [20/0] via 101.101.101.1, 00:22:22
C        11.11.11.11 is directly connected, Loopback0
33.0.0.0/32 is subnetted, 1 subnets
B        33.33.33.1 [20/0] via 101.101.101.1, 00:22:22
101.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        101.101.101.0/24 is directly connected, Ethernet0/0
L        101.101.101.11/32 is directly connected, Ethernet0/0
CE1#ping 33.33.33.1 so lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.1, timeout is 2 seconds:
Packet sent with a source address of 11.11.11.11
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/7/10 ms
CE1#

Second Step, Menghubungkan PE2 CE4 menggunakan EIGRP

PE2
PE2(config)#int e0/1
PE2(config-if)#vrf forwarding A
PE2(config-if)#no shut
PE2(config-if)#ip addr 34.34.34.3 255.255.255.0
PE2(config-if)#router eigrp A
PE2(config-router)#address-family ipv4 vrf A autonomous-system 300
PE2(config-router-af)#network 33.33.33.33 0.0.0.0
PE2(config-router-af)#network 34.34.34.3 0.0.0.0

CE4
CE4(config)#int lo0

CE4(config-if)#ip addr 44.44.44.44 255.255.255.255
CE4(config-if)#int e0/0
CE4(config-if)#ip addr 34.34.34.4 255.255.255.0
CE4(config-if)#router eigrp 300
CE4(config-router)#network 44.44.44.44 0.0.0.0
CE4(config-router)#network 34.34.34.4 0.0.0.0

Verifikasi

CE4#sh ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        34.34.34.0/24 is directly connected, Ethernet0/0
L        34.34.34.4/32 is directly connected, Ethernet0/0
44.0.0.0/32 is subnetted, 1 subnets
C        44.44.44.44 is directly connected, Loopback0
CE4#

*terlihat routingan mengarah ke CE1 belum ada dikarenakan routingan belum diredistribute pada PE2.

Third Step,  Redistribution di PE2, BGP EIGRP buat mbocorin routingan dari BGP ke EIGRP begitu pula sebaliknya

PE2
PE2(config)#router bgp 100
PE2(config-router)#address-family ipv4 vrf A
PE2(config-router-af)#redistribute eigrp 300
PE2(config-router-af)#router eigrp A
PE2(config-router)#address-family ipv4 vrf A autonomous-system 300
PE2(config-router-af)#topology base
PE2(config-router-af-topology)#redistribute bgp 100 metric 10000 1000 255 1 1500 < liatnya di sh interface e0/1 sesuaikan dengan kriteria disana meliputi metric bandwidth, delay, dll

Verifikasi

CE4#sh ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Gateway of last resort is not set

11.0.0.0/32 is subnetted, 2 subnets
D EX     11.11.11.1 [170/537600] via 34.34.34.3, 00:02:47, Ethernet0/0
D EX     11.11.11.11 [170/537600] via 34.34.34.3, 00:02:47, Ethernet0/0
33.0.0.0/32 is subnetted, 1 subnets
D EX     33.33.33.1 [170/537600] via 34.34.34.3, 00:02:47, Ethernet0/0
34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        34.34.34.0/24 is directly connected, Ethernet0/0
L        34.34.34.4/32 is directly connected, Ethernet0/0
44.0.0.0/32 is subnetted, 1 subnets
C        44.44.44.44 is directly connected, Loopback0
CE4#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/6 ms
CE4#

Pastikan CE1 terdapat ditabel routing CE4 dan juga bisa diping. Oh iya untuk PE1 CE1 itu gak perlu redistribute redistribute an karena mereka pakai BGP, jadinya cukup pakai send-community untuk melewatkan prefix dan itupun sudah bisa menjangkau vrf sebelah.

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.