Lab57. IS-IS Path Selection

Pemilihan jalur pada IS-IS didasarkan pada metric, jadi metric yang paling kecil akan dipilih sebagai jalur utama. Default metric pada IS-IS yaitu 10, apabila setiap melewati routing metric tersebut akan bertambah nilainya sesuai metric yang diset pada router tersebut.

Tujuan Lab :

  • Melakukan pemilihan jalur pada IS-IS dengan mengubah nilai metricnya.

Topologi Lab :

isis-path-selectionMetode Lab :

  • Set semua IP router dan loopback sesuai topologi di atas.
  • Set routing IS-IS level 2 pada semua router, seperti pada lab 1.
  • Pilih jalur utama menjadi lewat R4 dengan cara mengubah metric defaultnya pada R1, R2 dan R3.

Verifikasi lab :

  • Pastikan semua IP loopback router bisa saling ping.
  • Pastikan dari R1 ke R3 atau sebaliknya menggunakan jalur bawah saja, yaitu lewat R4.

Konfigurasi saat metricnya default

Router R1

hostname R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
ip router isis
!
interface FastEthernet0/1
ip address 14.14.14.1 255.255.255.0
ip router isis
!
router isis
net 49.0001.0010.0100.1001.00
is-type level-2-only

Router R2

hostname R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
ip router isis
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
ip router isis
!
router isis
net 49.0001.0020.0200.2002.00
is-type level-2-only

Router R3

hostname R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
ip router isis
!
interface FastEthernet0/1
ip address 43.43.43.3 255.255.255.0
ip router isis
!
router isis
net 49.0001.0030.0300.3003.00
is-type level-2-only

Router R4

hostname R4
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 14.14.14.4 255.255.255.0
ip router isis
!
interface FastEthernet0/1
ip address 43.43.43.4 255.255.255.0
ip router isis
!
router isis
net 49.0001.0040.0400.4004.00
is-type level-2-only

Lakukan traceroute untuk melihat jalur yang dipilih untuk mengirimkan data.

R1#tracer 3.3.3.3

Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 14.14.14.4 68 msec
    12.12.12.2 132 msec
    14.14.14.4 128 msec
  2 23.23.23.3 212 msec
    43.43.43.3 172 msec
    23.23.23.3 168 msec
R1#
R3#tracer 1.1.1.1

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 43.43.43.4 48 msec
    23.23.23.2 40 msec
    43.43.43.4 36 msec
  2 12.12.12.1 64 msec
    14.14.14.1 60 msec
    12.12.12.1 72 msec
R3#

Pada gambar di atas terlihat trafik menggunakan 2 jalur atau load sharing, kondisi yang kita inginkan adalah trafik dan R1 ke R3 atau sebaliknya melalui R4 saja. Dengan kata lain R4 merupakan link utama sedangkan R2 link backup.

Set metric pada jalur backup, set metric lebih besar agar trafik memilih metric yang lebih kecil untuk dijadikan jalur utama.

R1(config)#int fa0/0
R1(config-if)#isis metric 20 level-2
R1(config-if)#
R2(config)#int fa0/1
R2(config-if)#isis metric 20 level-2
R2(config-if)#
R3(config)#int fa0/0
R3(config-if)#isis metric 20 level-2

Lakukan traceroute kembali, terlihat jalur sudah sesuai harapan. Trafik dari R1 ke R3 atau sebaliknya hanya melalui R4 saja.

R1#tracer 3.3.3.3

Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 14.14.14.4 40 msec 48 msec 44 msec
  2 43.43.43.3 56 msec 40 msec 40 msec
R1#

Hal ini disebabkan jalur bawah memiliki metric yang lebih kecil daripada jalur atas.

R3#tracer 1.1.1.1

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 43.43.43.4 44 msec 52 msec 28 msec
  2 14.14.14.1 24 msec 68 msec 16 msec
R3#

Lihat nilai metricnya dari router yang sudah kita set tadi.

R1#sh clns interface
FastEthernet0/0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  ERPDUs enabled, min. interval 10 msec.
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 57 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x1, local circuit ID 0x2
    Level-2 Metric: 20, Priority: 64, Circuit ID: R2.02
    DR ID: R2.02
    Level-2 IPv6 Metric: 10
    Number of active level-2 adjacencies: 1
    Next IS-IS LAN Level-2 Hello in 8 seconds
R2#sh clns interface
FastEthernet0/1 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  ERPDUs enabled, min. interval 10 msec.
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 20 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x2, local circuit ID 0x3
    Level-2 Metric: 20, Priority: 64, Circuit ID: R3.02
    DR ID: R3.02
    Level-2 IPv6 Metric: 10
    Number of active level-2 adjacencies: 1
    Next IS-IS LAN Level-2 Hello in 7 seconds
R3#sh clns int
FastEthernet0/0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  ERPDUs enabled, min. interval 10 msec.
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 24 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x1, local circuit ID 0x2
    Level-2 Metric: 20, Priority: 64, Circuit ID: R3.02
    DR ID: R3.02
    Level-2 IPv6 Metric: 10
    Number of active level-2 adjacencies: 1
    Next IS-IS LAN Level-2 Hello in 2 seconds

Cek routing tabel juga bisa digunakan untuk melihat nilai metricnya.

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
i L2    1.1.1.1 [115/30] via 43.43.43.4, FastEthernet0/1
     2.0.0.0/32 is subnetted, 1 subnets
i L2    2.2.2.2 [115/30] via 23.23.23.2, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
i L2    4.4.4.4 [115/20] via 43.43.43.4, FastEthernet0/1
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet0/0
     43.0.0.0/24 is subnetted, 1 subnets
C       43.43.43.0 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
i L2    12.12.12.0 [115/30] via 23.23.23.2, FastEthernet0/0
     14.0.0.0/24 is subnetted, 1 subnets
i L2    14.14.14.0 [115/20] via 43.43.43.4, FastEthernet0/1
R3#

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.