Lab53. MPLS VPN – AToM (Any Transport Over MPLS)

Introduction

AToM digunakan untuk membuat koneksi transport Layer 2 melalui network MPLS. Transport yang dimaksud bisa berupa seperti gambar dibawah

atomNamun kali ini saya akan mencoba beberapa diantaranya Transport menggunakan Frame Relay, Ethernet, dan PPP saja.

Buat Topologi seperti berikut

frame-relayKeterangan:
PE: R1 dan R2
CE: R3, R4

Jadi nanti kita akan melewatkan paket data dari R3 ke R4 yang menggunakan encapsulasi Frame Relay/PPP/Ethernet kedalam cloud MPLS

1. Frame Relay

Oke percobaan pertama menggunakan encapsulasi frame relay

Langkah langkah:

  • aktifkan IGP di dalam backbone MPLS
  • aktifkan MPLS di masing masing interface PE yang mengarah ke backbone
  • aktifkan frame relay switching di PE
  • set interface PE yang mengarah ke CE agar menggunakan encapsulasi frame relay
  • aktifkan tunnel mpls di interface PE ke arah CE (L2 transport)
  • di CE aktifkan encapsulasi frame relay pada interfacenya
  • sesuaikan mapping dengan dlci nya
  • Tambahkan routing antar kedua PE, untuk kali ini saya menggunakan OSPF

PE Router R1

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface e0/0
 description ### Link to R2 ###
 ip address 12.12.12.1 255.255.255.0
 mpls ip
!
interface Serial1/0
 description ### Link to R3 ###
 encapsulation frame-relay
 frame-relay intf-type dce
!
router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
!
connect frelay Serial1/0 102 l2transport
 xconnect 2.2.2.2 10 encapsulation mpls
!
mpls ldp router-id Loopback0 force
!

PE Router R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface e0/0
 description ### Link to R1 ###
 ip address 12.12.12.2 255.255.255.0
 mpls ip
!
interface Serial1/0
 description ###Link to R4###
 encapsulation frame-relay
 frame-relay intf-type dce
!
router ospf 1
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 0
!
connect frelay Serial1/0 201 l2transport
 xconnect 1.1.1.1 10 encapsulation mpls
 !
mpls ldp router-id Loopback0 force
!

CE Router R3

!
interface Serial1/0
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 description ### Link PTP to R4 ###
 ip address 34.34.34.3 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 102
!

CE Router R4

!
interface Serial1/0
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 description ###Link PTP R3 ###
 ip address 34.34.34.4 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 201
!

Verifikasi MPLS VPN Frame Relay

R1#sh mpls l2trans vc 10

Local intf     Local circuit              Dest address    VC ID      Status    
-------------  -------------------------- --------------- ---------- ----------
Se1/0          FR DLCI 102                2.2.2.2         10         UP        
R1#
R2#sh mpls l2trans vc 10

Local intf     Local circuit              Dest address    VC ID      Status    
-------------  -------------------------- --------------- ---------- ----------
Se1/0          FR DLCI 201                1.1.1.1         10         UP        
R2#
R3#ping 34.34.34.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 34.34.34.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
R3#

==========================================================
==========================================================

2. MPLS VPN – AToM – Ethernet

Router R1 dan R2 akan menjadi router PE pada networks MPLS, sedangkan router R3 dan R4 akan menjadi router CE untuk dikoneksikan melalui transport Ethernet.ethernetPE Router R1

!
 interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
 interface e0/0
 ip address 12.12.12.1 255.255.255.0
 mpls ip
 !
 interface e0/1
 xconnect 2.2.2.2 10 encapsulation mpls
 !
 router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
 !

PE Router R2

!
 interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
 interface FastEthernet0/0
 description ###Link to R1###
 ip address 12.12.12.2 255.255.255.0
 mpls ip
 !
 interface FastEthernet0/1
 xconnect 1.1.1.1 10 encapsulation mpls
 !
 router ospf 1
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 0
 !

CE Router R3

!
 interface FastEthernet0/0
 description ###Link to R1###
 ip address 34.34.34.3 255.255.255.0
 !

CE Router R4

!
 interface FastEthernet0/0
 description #Link to R2###
 ip address 34.34.34.4 255.255.255.0
 !

Verifikasi MPLS VPN Ethernet

R1(config)#do sh mpls l2trans vc 10
Local intf     Local circuit              Dest address    VC ID      Status
 -------------  -------------------------- --------------- ---------- ----------
 Et0/1          Ethernet                   2.2.2.2         10         UP
 R1(config)#
R2#sh mpls l2transport vc 10
Local intf     Local circuit              Dest address    VC ID      Status
 -------------  -------------------------- --------------- ---------- ----------
 Et0/1          Ethernet                   1.1.1.1         10         UP
 R2#
R3(config)#do ping 34.34.34.4
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 34.34.34.4, timeout is 2 seconds:
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/7 ms
 R3(config)#

==========================================================
==========================================================
3. MPLS VPN – AToM – PPP

Router R1 dan R2 akan menjadi router PE pada networks MPLS, sedangkan router R3 dan R4 akan menjadi router CE untuk dikoneksikan melalui transport PPP.

pppPE Router R1

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface e0/0
 description ###Link to R2###
 ip address 12.12.12.1 255.255.255.0
 mpls ip
!
interface Serial1/0
 encapsulation ppp
 xconnect 2.2.2.2 10 encapsulation mpls
!
router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
!

PE Router R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface e0/0
 description ### Link to R1 ###
 ip address 12.12.12.2 255.255.255.0
 mpls ip
!
interface Serial1/0
 encapsulation ppp
 xconnect 1.1.1.1 10 encapsulation mpls
!
router ospf 1
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 0
!

CE Router R3

!
interface Serial1/0
 ip address 34.34.34.3 255.255.255.0
 encapsulation ppp
!

CE Router R4

!
interface Serial1/0
 ip address 34.34.34.4 255.255.255.0
 encapsulation ppp
!

Verifikasi MPLS VPN PPP

R1#sh mpls l2trans vc 10

Local intf     Local circuit              Dest address    VC ID      Status    
-------------  -------------------------- --------------- ---------- ----------
Se1/0          PPP                        2.2.2.2         10         UP        
R1#
R2#sh mpls l2trans vc 10

Local intf     Local circuit              Dest address    VC ID      Status    
-------------  -------------------------- --------------- ---------- ----------
Se1/0          PPP                        1.1.1.1         10         UP        
R2#
R3(config-if)#do ping 34.34.34.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 34.34.34.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/24 ms
R3(config-if)#

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.